Security | Threat Detection | Cyberattacks | DevSecOps | Compliance

Basic Authentication vs. Modern Authentication and How to Enable It in Office 365

According to a Verizon report, the majority of data breaches are made possible by compromised credentials, especially on email servers. Social engineering, credential phishing and brute force attacks are some of the methods used by malicious actors to steal credentials. To improve the security of Office logins and help prevent data breaches, Microsoft introduced the modern authentication method.

An Overview of Amazon S3 Browser for Windows

Amazon S3 is a popular cloud storage that is widely used around the world. You can manage Amazon S3 cloud storage in the web interface by using a web browser. We have explained the alternative methods to manage files stored in S3 buckets in the blog post about mounting Amazon S3 as a drive for cloud file sharing, but in that blog post the emphasis was on the command line interface of operating systems such as Linux, Windows, and macOS.

Backing Up Microsoft 365 SharePoint Data to Amazon S3: A Comprehensive Guide

SharePoint backup and Office 365 backup, in general, are an essential part of an organization’s data protection and security strategy. Microsoft 365 backups can be stored on-premises, but the recommended practice is to follow the 3-2-1 backup rule and store backup copies in the cloud too. With the NAKIVO solution, you can implement this effective backup strategy to protect Microsoft 365 data in SharePoint Online as well as in Exchange Online, Microsoft Teams, and OneDrive for Business.

NAKIVO Backup & Replication v11.2 Drives Innovation and Global Expansion

NAKIVO Inc., a trusted provider of backup, disaster recovery and ransomware protection solutions, announced the general availability of NAKIVO Backup & Replication v11.2 on March 10, 2026. The release advances the company's ongoing commitment to helping organizations protect critical data across increasingly complex IT environments. The new version arrives amid significant business momentum, with over 16,000 active customers now operating across 191 countries.

A Complete Guide to Instant VM Recovery on VMware vSphere

Unexpected downtime can disrupt your workflows in an instant. Virtual machines (VMs) power critical workloads, and when one fails, every second counts. The time needed for a full VM recovery depends on multiple factors, such as the size of virtual disks, storage performance, network speed and the recovery method.

6 Ways to Move a VMware VM from One EXSi Host to Another

When you have more than one ESXi host in your environment, you may need to migrate virtual machines from one host to another. The reason can be rational resource usage or insufficient computing resources on one of the hosts. Learn about the methods available to you to migrate virtual machines in VMware vSphere with and without vCenter.

"503 Service Unavailable" Error on the vSphere Web Client: What Should You Do?

VMware vCenter Server, the centralized management point in vSphere, is used for managing ESXi hosts, clusters, VMs, and other components in your virtualized data center. This blog post addresses the 503 Service Unavailable that you may get in vSphere Client when you try to connect to vCenter. Read to learn about the potential causes of this error and how to fix it. NAKIVO for VMware vSphere Backup Complete data protection for VMware vSphere VMs and instant recovery options.

VMware ESXi vs vSphere vs vCenter: Complete Comparison

VMware offers a wide range of products, and understanding their different use cases may be overwhelming. In this blog post, we cover the differences between three commonly used technologies in VMware environments: It’s important to note that any ESXi vs. vSphere vs. vCenter comparison should start with a caveat: these technologies are complementary rather than substitutes for one another. NAKIVO for VMware vSphere Backup Complete data protection for VMware vSphere VMs and instant recovery options.

Fix VMware Error: Virtual Machine Disks Consolidation Needed

The VMware virtual machine disks consolidation is needed error usually appears when snapshots fail to merge correctly with the main virtual disk. This problem often occurs after incomplete backups, canceled snapshot deletions, or low storage space. Left unresolved, it can slow down your VM or even risk data corruption. Read this blog to learn why the virtual machine consolidation needed status occurs and how to resolve it safely.

Free ESXi: Restrictions and Limitations

VMware is a market leader in virtualization solutions, and VMware ESXi is a renowned type 1 hypervisor. Increasingly, individual users and organizations are deploying ESXi servers in their environments to run virtual machines. An ESXi hypervisor is provided as part of VMware vSphere, which, in turn, comes with different licensing options for each edition. Each VMware vSphere edition has its own price, but VMware also provides a free version of ESXi.